Pourquoi cette erreur est - elle signalée lors de l'utilisation de la commande Hadoop?

Questions et réponses du rseoc 2021-12-30 07:40:05 阅读数:935

pourquoi cette erreur est elle

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.hadoop.security.authentication.util.KerberosUtil (file:/Users/jokerxu/tools/hadoop-2.10.0/share/hadoop/common/lib/hadoop-auth-2.10.0.jar) to method sun.security.krb5.Config.getInstance()
WARNING: Please consider reporting this to the maintainers of org.apache.hadoop.security.authentication.util.KerberosUtil
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
21/12/23 10:25:18 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
mkdir: `/wc_input': Input/output error




Adopter les réponses:

hadoopSous le Répertoire d'installationlib/native Non introduit dans les variables d'environnement .
export JAVA_LIBRAY_PATH=/usr/local/hadoop/lib/native
Puis redémarrez


版权声明:本文为[Questions et réponses du rseoc]所创,转载请带上原文链接,感谢。 https://primo.wiki/2021/12/202112300740037148.html